[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#318590: curl 7.14.0-5: OpenSSL vs GnuTLS is still a problem

On Wed, Aug 24, 2005 at 04:23:19PM +0200, Marco d'Itri wrote:
> On Aug 24, Domenico Andreoli <cavok@debian.org> wrote:
> > in the meanwhile new packages can be built using the gnutls variant of
> > libcurl3. be aware that libcurl3 and libcurl3-gnutls currently cannot
> > be installed at the same time.
> What is the point then? They *will* be needed at the same time.
> If they cannot be installed on the same system then looks like you are
> wasting your time.

the conflict is temporary. as soon as curl is fixed with this regard the
conflict will be removed and the packages depending on libcurl3-gnutls
will be bugged to be rebuilt.

> That "solution", BTW is a disgusting hack.

Daniel will be surely happy to see better patches. regarding me,
i prefer disgusting over inexistent.

if only Daniel liked the idea of using plugins in curl... eh, Daniel?

> Again, there should be no reasons to need to use a openssl instead of
> gnutls. If some program really needs it, then it should be linked to a
> *special* libcurl-with-openssl library until it can be fixed.
> But the default should be to use gnutls.

gnutls is not mature, it has been just added. people willing to test
it and signal bugs are welcome.

-----[ Domenico Andreoli, aka cavok
 --[ http://people.debian.org/~cavok/gpgkey.asc
   ---[ 3A0F 2F80 F79C 678A 8936  4FEE 0677 9033 A20E BC50

Reply to: