[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Libtool and packaging

Hi there,

I'm finally on the "working" computer. After having tried to build the .dev package again, here is the missing info. The command used for compiling 'geo' (one of the binaries that must be linked to librheolef.so (the shared library)) is the following one :

/bin/sh ../../libtool --mode=link i386-linux-g++ -O2 -ansi -Wall -Wno-unused -o geo xgeo.o ../lib/librheolef.la i386-linux-g++ -O2 -ansi -Wall -Wno-unused -o .libs/geo xgeo.o ../lib/.libs/librheolef.so -L/usr/lib/gcc-lib/i486-linux/3.3.5 -L/usr/lib/gcc-lib/i486-linux/3.3.5/../../.. -ldl -lstdc++ -lm -lc -lgcc_s -Wl,--rpath -Wl,/here/is/the/top/build/dir/nfem/lib/.libs
creating geo

When the binary is to be installed, here's the error message I receive :

/bin/sh ../../libtool --mode=install /bin/sh ../../config/install-sh -c 'geo' '/here/is/the/top/build/dir/debian/rheolef/usr/bin/geo' /bin/sh ../../config/install-sh -c geo /here/is/the/top/build/dir/debian/rheolef/usr/bin/geo
libtool: install: warning: cannot relink `geo'
libtool: install: warning: `../lib/librheolef.la' has not been installed in `/usr/lib'

Now the funny thing is that if I copy the command above (used to install the binary) and execute it by myself, it works (well almost, I at least get a binary file in debian/rheolef/usr/bin/, but it's still linked to /here/is/the/top/build/dir/nfem/libs/.libs/librheolef.so.513).

I downloaded flac source package since it was quite similar to what I'm trying to do, that is an executable depending on a shared library not yet installed, and all of that from the same sources. The main difference I found was the --rpath missing option in the compilation of flac executable.

I tried to find a way to remove it but with no luck, I could only append a second --rpath to the end of the command, which was of course ignored.

I'm not quite sure what to do now, I'll try to use flac sources to find a way out...

Thanks for helping...

Alexis Papadopoulos

Reply to: