[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: raidtools2 -> mdadm change: woes and problems

On Wed, Jun 22, 2005 at 07:16:22PM +1000, Brian May wrote:

> On 2 of the systems I have upgraded, I had serious problems with
> mdadm.
> The documentation said that there was no need for a config file, and I
> never used a 2.2 kernel, so the paragraphs starting with "If your RAID
> array was created on a 2.2 Linux kernel patched with RAID...." seem
> irrelevant.
> However, after rebooting, the raid devices would renumber themselves
> starting from /dev/md0 and up.
> This meant the entries in /etc/fstab were now wrong.
> I tried starting /dev/md4 manually, but I got /dev/md0 instead.
> Eventually, I got /dev/md4 up and running, manually, and the computer
> resumed booting.  After rebooting the computer, and the same problem
> reoccurred...
> Repeat previous paragraph numerous times with different variations.
> I tried assembling the RAID with the --update=super-minor option (as
> well as all the other options), but it didn't seem to help.
> In the end, I gave up and changed /etc/fstab to the new system.
> I no longer have access this machine, the other machine doesn't seem
> to have the problem anymore.
> How is this meant to work?

I am trying to remember my experience, so this might not be completely

In my setup I have lilo booting different root RAID partitions, and the
normal way here is with a home made kernel having RAID support built in
(not as modules).

If RAID support is compiled into the kernel, and you created the RAID to use
the minor numbers, things will work regardless of the root partition you

However, if is built as modules, as in an initrd, that automatic detection
does not work and you need to either use a config file, or trust what mdrun
builds (I think mdrun is run if no config file is found). In my system
what mdrun builds is different from what I had set, so a config file is
needed in this case.

Managing a single initrd boot from different root RAID partitions needed a
bit more hack. Otherwise will assemble the one it was built from, but that
will not work if you want to use a different one as root.



Reply to: