[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: raidtools2 -> mdadm change: woes and problems

>>>>> "Martin" == Martin Michlmayr <tbm@cyrius.com> writes:

    Martin> * Clemens Schwaighofer <cs@tequila.co.jp> [2005-06-21
    Martin> 14:44]:
    >> Are there any kind of documents describing how to move from
    >> raidtools safely to mdadm without loosing a raid?

    Martin> http://www.debian.org/releases/stable/i386/release-notes/ch-upgrading.en.html#s-mdadm


On 2 of the systems I have upgraded, I had serious problems with

The documentation said that there was no need for a config file, and I
never used a 2.2 kernel, so the paragraphs starting with "If your RAID
array was created on a 2.2 Linux kernel patched with RAID...." seem

However, after rebooting, the raid devices would renumber themselves
starting from /dev/md0 and up.

This meant the entries in /etc/fstab were now wrong.

I tried starting /dev/md4 manually, but I got /dev/md0 instead.

Eventually, I got /dev/md4 up and running, manually, and the computer
resumed booting.  After rebooting the computer, and the same problem

Repeat previous paragraph numerous times with different variations.

I tried assembling the RAID with the --update=super-minor option (as
well as all the other options), but it didn't seem to help.

In the end, I gave up and changed /etc/fstab to the new system.

I no longer have access this machine, the other machine doesn't seem
to have the problem anymore.

How is this meant to work?
Brian May <bam@debian.org>

Reply to: