[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: relocation error(s) with various binaries

Ok, I've solved this for my system. I removed X and all associated libraries and started with a system without /usr/X11R6. Then I reinstalled from stable and I have a system working without the errors mentioned below. If I get brave in the next little while I'll try sid, but I need a working system ATM, so it won't be too soon. Thanks to all those who made suggestions.


On Thu, 16 Jun 2005, Chris Gorman wrote:

On Thu, 16 Jun 2005, Peter Samuelson wrote:

[Chris Gorman]
+ exec /usr/lib/mozilla-firefox/firefox-bin -a firefox
/usr/lib/mozilla-firefox/firefox-bin: relocation error:
/usr/lib/libXrender.so.1: undefined symbol: _Xglobal_lock

Try reinstalling libx11-6.
Done.  It was one of the ones I reinstalled already, but I tried it again.
Unfortunatly the errors persist.
Verify that it has the symbol in question:

  nm --dynamic /usr/X11R6/lib/libX11.so.6 | grep _Xglobal_lock

000c6910 B _Xglobal_lock

should reveal it as a "B" symbol (uninitialised data).

I've also tried reinstalling all of mozilla in the event that it had
become corrupt.  This also didn't resolve the problems.  :(  Any other
suggestions?  (I'm thinking about removing all of X and starting over with

Reply to: