[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Let's remove mips, mipsel, s390, ...

On Mon, Feb 21, 2005 at 03:53:44PM +0100, Goswin von Brederlow wrote:
> What would help save many hours on slow systems is having a script
> automatically set "Dep-Wait: libbfoo (>> 1.2-3)" for all new sources
> according to Build-Depends to prevent useless buildd attempts and
> failures and manual work to retry them.

Why do the build servers install all the dependencies only to find out
that some installed versions are insufficient for the build?

Surely this can be determined _before_ installing the dependencies?
No new information is available after install that wasn't available

Is the problem that you use apt-get to install the current version, and 
then check what you got? Because you can't tell apt-get to install
at least version X else fail?

Hamish Moffatt VK3SB <hamish@debian.org> <hamish@cloud.net.au>

Reply to: