[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Select which conffiles shall be raplaced an which not

|--==> Matthew Palmer writes:

  MP> [1  <text/plain; us-ascii (quoted-printable)>]
  MP> On Tue, Nov 16, 2004 at 01:29:38PM +0100, Free Ekanayaka wrote:
  >>When running apt-get dist-upgrade I'd like to be able to set a list of
  >>packages whose  confiles   shall be  replaced  by   the newer versions
  >>supplied  by the  package  (if any)  , while  other packages' confiles
  >>should be keep the locally modified version.
  >>Is this possible?

  MP> Not that I know of, but it would be an interesting modification to make to
  MP> dpkg (which is the program that manages the replacement of modified
  MP> conffiles).

Yes,  I  think so.  There are  the  dpkg --force-conf(new|old|default)
options, which you can tell apt-get  to use with DPpk::Options, but as
I guess apt-get dist-upgrade calls dpkg with all packages at once, you
can't   select for which  packages  use the force-conf  option and for
which not.



Reply to: