[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ITP: cddb.bundle -- CDDB Bundle for GNUstep

On Monday 04 October 2004 20:23, Frank Küster wrote:
> Hi,
> could you do me the favor of producing readable mails, i.e. with
> empty lines between text and quotes, and sensible line lengths?
> Gürkan Sengün <gurkan@linuks.mine.nu> wrote:
> > Frank,
> >
> >> Build-Depends: debhelper (>= 4.0.0), libgnustep-gui0-dev (>=
> >> 0.8.3-1) It seems to me this will make it a binary that requires
> >> GNUstep to run it? Then, for the hundredth time,
> >> please call the package gnustep-cddb.bundle or something like
> >> that.
> >
> > No. I have already compromised the upstream name by adding
> > ".bundle", as suggested by the last flamewar on the subject as the
> > only reasonable course of action.
> I must have missed this thread... What is ".bundle" meant to
> indicate?

On NeXT-Step systems the ".bundle" suffix of a directory indicates a 
dynamically linkable module (basically like a shared lib). But besides 
the shared lib(s) it also includes other resources, which are needed to 
run the bundle, e.g. GUI data, graphical and audio data, language 
dependent data like translation files, other data which is needed by 
the module.



Reply to: