[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Pre-Depends of #CDD#-common meta packages from cdd-common

On Fri, Jun 11, 2004 at 07:31:16PM +0200, Andreas Tille wrote:
> On Fri, 11 Jun 2004, Colin Watson wrote:
> > I think you might have wanted 'command -v', and that's indeed not
> > portable. base-passwd.postinst does this:
> >
> > # A cut-down version of 'which' from debianutils.
> Hmmm, which is part of debianutils which is required.  Why do I
> have to work around this?

You didn't read the patch in detail. (It does *not* use 'which'; it
reimplements it in pure shell. 'which' isn't reliably-enough portable.)


Colin Watson                                  [cjwatson@flatline.org.uk]

Reply to: