[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ITA: filler - Simple game in Java

On Tue, 2004-05-11 at 11:40, Gunnar Wolf wrote:
> James Damour dijo [Tue, May 11, 2004 at 08:25:52AM -0400]:
> > Good evening.  My name is James Damour, and I would like to adopt the
> > filler package that the Debian QA team has orphaned.  I have made my
> > first modifications to the package, and I have uploading them to
> > http://mentors.debian.net.
> Hi,
> I cannot offer you to sponsor your package, as I understand no Java,
> and any error would probably slip under my nose. Anyway, if you have
> the package ready, please retitle bug #232868 to 'ITA: filler - Simple
> game in Java' - You can do this by sending the following line as a
> mail to control@bugs.debian.org:
> retitle 232868 ITA: filler - Simple game in Java
> I noticed you already replied to that bug report, but when people look
> at the WNPP packages, filler still appears as orphaned - do this just
> to save other people the effort in opening the report and checking.

> > I would appreciate it if a sponsor could review my packaging, and let me
> > know what I should change in order to get it ready for upload to the
> > Debian archive.  I've fixed all lintian or linda errors, and the
> > remaining linda warning may be a bug (as a game, filler needs to be
> > rwxr-sr-x and linda is expecting rwxr-xr-x).
> > 
> > I expect that I'll get a FTBFS error because I can not specify a
> > compliant Java Development Kit from within the Debian archive (filler
> > requires Swing technology, and I haven't found a VM that will build it,
> > but I'm still looking).  Any assistance in this area would be greatly
> > appreciated.
> If your package requires a non-free JDK, then it will enter contrib
> (instead of main) and will not be autobuilt, so don't worry, you will
> not get the dreaded FTBFS ;-) Just please note somewhere visible
> (i.e. in /usr/share/doc/filler/) what JDK did you use to compile it
> and where can it be found. Also, double check: Can Filler be used with
> any of the existing JVMs in Debian? If not, it would not be useful at
> all, and instead of adopting it, you should file for its removal from
> the archive.

The file, /usr/share/doc/filler/README.Debian mentions both the
Blackdown and the Sun VMs.  It does not *explicitly* state that these
are needed to rebuild the source; do you think that I should update the
file to say so?  I've tried gij-3.3 and both Kaffe and SableVM from Sid,
and neither currently support the Swing APIs used by filler, but I'm
very hopeful that they will quite soon.  As such, and considering the
age of the package (it's been in Debian for over 3 years) I'd prefer to
leave the package in Debian, and just have it limp along until FLOSS
Java catches up to it.
> Greetings,

Thank you for your feedback.

James Damour (Suvarov454) <suvarov454@users.sourceforge.net>

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: