[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: AMD64 Port: Almost all packages are ready to be uploaded

On 04-May-09 17:47, Frederik Schueler wrote:
> Hi,
> On Sun, May 09, 2004 at 04:14:13PM +0200, Andreas Jochens wrote:
> > Yes, you can find my xfree86 patch in the BTS (#240889). It simply 
> > switches off the 'lib64' installation feature in the original 
> > xfree86 sources for amd64 and uses 'lib' instead. Please try my second 
> > patch (the first one was incomplete).
> Great. Did you build glide, too? I cannot find any patches of yours in
> the bts and xfree86 build-depends on it.

This is a bug in my patch. I do not have any patch for glide on amd64.

xfree86 build-depends on libglide2-dev and libglide3-dev for i386 only. 
I just added the build-depends for amd64 when I first experimented with 
xfree86 on amd64 and simply forgot to remove them later.

You can just remove the dependencies on libglide2-dev and libglide3-dev 
for amd64 from the Build-Depends in debian/control in my patch. Then 
xfree86 compiles without problems (at least for me). 

I will send an updated patch without these Build-Depends to the BTS in a 
separate mail.

Please report if you can successfully build and install xfree86 on 

Andreas Jochens

Reply to: