[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: raising severity of reports filed for packages build-depending on gcc-3.2

* Matthias Klose <doko@cs.tu-berlin.de> [2004-03-31 09:18]:
> 	#236436		glcpu
> 	#236440		id3lib3.8.2
> 	#236457		id3lib3.8.3

They build just fine on mips and i386 with GCC 3.3.

> 	#236451		savant

This one has a Buil-Depends on g++-3.2 | g++-3.3.  This just has to be
dropped (both, since gcc is build-essential).  Builds on i386 with 3.3.

> 	#236437		dv-utils

Not a GCC bug, but one in the package; easy to fix and maintainer will
do do.

> 	#236450		xirssi

Removed from the archive.

> 	#236454		ivtools

Looks like a bug in the package rather than the compiler.

> 	#236459		systemimager

Needs 3.2 on ia64 only.  Why?

> 	#236442		vlc

Needs 3.2 on PowerPC only.  Can anyone test if this is still true?

>       #236443         juk

       juk |     1.95-1 |       testing | source, alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
       juk |     1.95-3 |      unstable | source, alpha, arm, hppa, ia64, m68k, mips, mipsel, powerpc, s390, sparc
       juk |  4:3.2.1-1 |      unstable | i386

The KDE 3.2 package builds a juk binary now, but this will maybe not
enter testing soon.  So perhaps a fixed juk should be uploaded
directly to testing-proposed updates?

What are your plans with gcc-3.0?  It seems there are only a few
build-depends on hppa.
Martin Michlmayr

Reply to: