[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: broken package dependencies, surgery on package database

I put my answers in-line ...

>   What do you mean by "irretrievably stuck"?  ie,
> what happens when you
> try to purge the packages from aptitude?  Or
> dselect/dpkg for that
> matter; it should be the same.
Well, after dselect removed the kernel and the alsa
package w/o purging i2c and lm-sensors, the packages
were marked as broken by dselect which caused the
install step of dselect to abort with an error 100.
Similarly, in aptitude the broken packages prevent any
packages from getting processed.

So, before posting, the steps I took were:

1.  tried dpkg 
2.  tried dpkg with every conceivable force option
3.  re-compiled the 2.4.23 kernel and the modules (I
no longer had the originals) and re-installed them,
thinking that I could then, perhaps, remove the
packages in the correct order; didn't work
4.  now, dpkg and dselect crap-out saying the packages
are beyond repair and need to be re-installed

>   You should just be able to remove the packages
> without hacking the
> package database; if that's failing, we should try
> to remove them
> cleanly before going in with a chainsaw.  Most
> likely a prerm script is
> failing, in which case, if worst comes to worst, you
> can just edit the
> offending script to fix it.
I think this was probably the case originally and in
the steps above, I should have tried to edit the prerm
script. But, I didn't. Now it doesn't seem to even get
to the prerm script. I believe that before I tried
re-installing dselect would make it all the way to the
prerm script.



Do you Yahoo!?
Yahoo! Search - Find what you?re looking for faster

Reply to: