[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Issues with Epoch

* Evan Prodromou <evan@debian.org> [040226 16:53]:
> Both the ScriptKit and greg used to be distributed separate from
> gnustep-guile, and they've got different internal version numbers. But
> I think the package version has to be the same for all three binary
> packages. I tried making packages with different version numbers, and
> although they worked well, the ftp service on master barfed when it
> saw them.

How did it barf? As there are source-packages with binaries having
different versions around there should be some possibility to get
them in.

If a .deb only contains one program and this is known under a
specific version than it would be best to also have the .deb
have this version. (From the princible of least suprise).

Is having them combined upstream merely a cosmetic move and/or
to allow users downloading all they need in one file, or will
they be integrated tougher? If this is merely a combination
one could also think about splitting the source in parts again
and making more than one source package out of it.

  Bernhard R. Link

Sendmail is like emacs: A nice operating system, but missing
an editor and a MTA.

Reply to: