[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Use of ~ in package versions

On Sun, 25 Jan 2004, Matthias Klose wrote:

> The ~ character can be used in package versions, so that x.y~pre1-1 <<
> x.y-1, but it's currently not used and lintian complains about
> it. nevertheless it seems to work. can this notation already be used
> for packages, which could be part of sarge? what are the required
> versions of dpkg and apt to use this notation?

It'd be best to wait until a version of dpkg and apt that handle ~ hit stable.
Which means no package in sarge can use ~ in the version.

Please check their changelogs for the versions that added support.

Reply to: