[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apt 0.6 in experimental



On Thu, Jan 01, 2004 at 10:56:00PM -0500, Nathaniel W. Turner wrote:
> "Failed to fetch 
> http://debian.houseofnate.net/dists/unstable/Release  Unable to find expected 
> entry  nwt/binary-i386/Packages in Meta-index file (malformed Release 
> file?)".  (This is with apt 0.6.10.)

Oh. Also, you're expected to have entries for the md5sum & size
of the uncompressed Packages files *even if you only distribute the
compressed versions*. That's quite important for debootstrap's caching,
and possibly apt's.

Oh, and your problem is that your paths should be relative to the
directory the Release file's in, not the directory dists/ is in. ie:

 a2325b24d36c4a6678fb213198c3fbbd             1366 dists/unstable/nwt/binary-i386/Packages

should be:

 a2325b24d36c4a6678fb213198c3fbbd             1366 nwt/binary-i386/Packages

> Failed to fetch http://debian.houseofnate.net/dists/unstable/Release  Unable 
> to find expected entry  nwt/binary-i386/Packages in Meta-index file 
> (malformed Release file?)

See? No "dists/unstable" before the nwt.

Cheers,
aj

-- 
Anthony Towns <aj@humbug.org.au> <http://azure.humbug.org.au/~aj/>
I don't speak for anyone save myself. GPG signed mail preferred.

               Linux.conf.au 2004 -- Because we can.
           http://conf.linux.org.au/ -- Jan 12-17, 2004

Attachment: pgpGQrtV333Y1.pgp
Description: PGP signature


Reply to: