[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: security enhanced debian branch?

On Fri, Dec 19, 2003 at 12:19:56PM +1100, Russell Coker wrote:

> Given that you don't have direct access to anything other than i386 I suggest 
> that we initially only enable it for that platform.

  That's not a bad idea, I've updated my unstable package to do just

> Of course if someone who has direct access to another platform wants to 
> generate packages for it then that would be great!  They could get support 
> for their platform at the same time as i386.

  That would be a big help and should be simple enough for anybody
 interested.  Building the unstable package is a simple matter of installing
 the build-dependencies and making a minor edit to 'rules.patch' 
 changing it from:

# not applied by default
debian_patches += protector


ifeq (,$(findstring $(DEB_TARGET_ARCH),i386))
debian_patches += protector

  That's really all there is to it.  For the stable distribution it's a
  bit more involved, but not too difficult:



Reply to: