[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: GPM to 1.20.1?

Ken Bloom <kabloom@ucdavis.edu> wrote:
> Is it possible to upgrade GPM in unstable to 1.20.1 (at least) which has
> been out for a long time now. It would fix a lot of brokenness in GPM.

> There was a previous discussion in March about this topic, nothing ever
> came of it.

> http://lists.debian.org/debian-devel/2003/debian-devel-200303/msg00748.html

> There were some test packages referenced, I have been using them for 6
> months now without any problems, except for the binary compatibility
> problem mentioned in the post. This would be a very good time to upgrade
> gpm and transition all of the packages compiled against it.

I've just reread the thread and it does not give evidence that 1.20.1
is indeed a lot better and than 1.19.6+debian-patches.

> Any thoughts?

Afaict updating GPM would be a nice piece of work, requiring these
* Understand Debian patches.
* Verify which of them are necessary.
* doing lots of testing, with different mice. This involves pinging
* clean up stuff and get it integrated into upstream.
* resolve soname issue.

> (I'm not a DD so I can't take any initiative in the upgrade myself)

None of the things noted above require DD privileges. :-) However if
somebody != warp@debian.org intends to do it (s)he would have to add
* coordinate with maintainer
to the TODO.
            cu andreas
Hey, da ist ein Ballonautomat auf der Toilette!
Unofficial _Debian-packages_ of latest unstable _tin_

Reply to: