[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: booting problems after installing lm-sensors kernel modules from sid / can't mount root fs

Manuel Bilderbeek wrote:
OK, but I still have the LinuxOLD entry in my LILO menu. Since I'm running stock kernels, this should be starting my previous kernel anytime. So, I chose the option, and it booted until it had to mount the root fs. There I got a kernel panic: can't mount root fs. (No clear reason was mentioned...) Oops. My root fs is /dev/hda6, which is an ext3 fs. Even specifying
LinuxOLD root=/dev/hda6
didn't help.

OK, problem is solved, thanks to Mike Dornberger (and sorry for not checking this myself, I remembered it worked before, so I assumed it was OK):
I forgot this line in my lilo.conf:

I remember people using a stock kernel for the first time and having this problem too. It seems that at least some older version of the installation scripts do not adjust the lilo.conf correctly. Someone please check if this is done properly now (i.e. addition of the initrd option).

So, I took my older (Woody-beta) installation cd and booted with "rescue root=/dev/hda6". Also, this didn't work out: again a kernel panic, because it can't mount the root fs... This time there was some error about "unsupported optional features".

Any idea about this then?

Best regards,

Manuel Bilderbeek

Reply to: