[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

booting problems after installing lm-sensors kernel modules from sid / can't mount root fs

Hello all,

A couple of days ago, I installed these packages from sid:
 lm-sensors-2.4.21-4-k7 2.8.0-1
 i2c-2.4.21-4-k7 2.8.0-1

I have done this before many times, to save myself the trouble of compiling these kernel modules myself. I'm running a testing system with the 2.4.21-4-k7 stock kernel, you see.

Anyway, this time it didn't work out. When I rebooted my system next time, there was some error during boot which had at least this text in it "S20modutils Segmentation fault". So, my interpretation is that during the loading of these new kernel modules, there occured a segmentation fault in the module load program. After this message there was a little bit more text (about USB), but then a hang.
In other words: I couldn't boot the system anymore.

OK, but I still have the LinuxOLD entry in my LILO menu. Since I'm running stock kernels, this should be starting my previous kernel anytime. So, I chose the option, and it booted until it had to mount the root fs. There I got a kernel panic: can't mount root fs. (No clear reason was mentioned...) Oops. My root fs is /dev/hda6, which is an ext3 fs. Even specifying
LinuxOLD root=/dev/hda6
didn't help.

So, I took my older (Woody-beta) installation cd and booted with "rescue root=/dev/hda6". Also, this didn't work out: again a kernel panic, because it can't mount the root fs... This time there was some error about "unsupported optional features".

I tried some more tricks, like making boot floppies with a bf2.4 flavour (of Woody), which I got from some Debian FTP. No go, can't mount root fs.

I tried some more suggestions from people in #debian on irc.freenode.net, but nothing worked.

In the mean time, I have fixed my "Linux" boot, by using a Knoppix cd and removing the module names from /etc/modules. However, I still can't boot my LinuxOLD stuff.

Is there anyone who can tell me what is going wrong?
I know I could boot my LinuxOLD thing in the past. It's just a long time ago I needed it.

Best regards,

Manuel Bilderbeek

Reply to: