[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [RFC] Debian ruby policy (Re: Fw: Re: Ruby 1.8 transition plan; debian-ruby)



At Thu, 21 Aug 2003 20:33:10 +0300,
Dmitry Borodaenko wrote:
> 
> On Thu, Aug 21, 2003 at 02:53:12AM +0900, Fumitoshi UKAI wrote:
>  FU> Dmitry Borodaenko <angdraug@debian.org>
>  FU>  libyaml-ruby1.8 (<- libyaml-ruby)
> 
> I think that since whytheluckystiff is developing Syck/YAML right in the
> Ruby CVS, there is little chance for a separation of libyaml-ruby1.8 in
> the near future, and I'm quite happy with it being maintained by akira
> as part of ruby1.8.

Ok, I see.
 
> I am inclined to keep libyaml-ruby1.6 (renamed from current libyaml-ruby
> as soon as ruby-defaults is out), and make a libyaml-ruby metapackage
> that depends on libyaml-ruby1.6 | libyaml-ruby1.8, so that a program
> that doesn't care about Ruby version would pull in either 1.6 or 1.8
> version, depending on the version of Ruby installed.

Yes, please keep libyaml-ruby1.6 while ruby1.6 around.
Regarding libyaml-ruby, do you want to maintain it by yourself?

Now, ruby-defaults packages contains all -ruby packages for -ruby1.6 
packages that are built from ruby1.6. So, as the same rule, I suppose
ruby-defaults provides all -ruby packages for -ruby1.8 in ruby1.8 
source package, after ruby-defaults becomes ruby1.8. But I'm not sure
which is the better way.

Regards,
Fumitoshi UKAI

Attachment: pgpEjgDOfuTSz.pgp
Description: PGP signature


Reply to: