[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: default MTA for sarge

On Sun, Jul 13, 2003 at 01:25:02PM +0200, Andreas Metzler wrote:
> Daniel Silverstone <dsilvers@digital-scurf.org> wrote:
> > Since woody didn't release with exim4 at all, I'm all for releasing with
> > exim 3 by default, having exim 4 there for people who want it, and then
> > in sarge+1 swapping it over for exim4 by default, then exim3 there if
> > you want it. sarge+2 can remove exim3.
> Exim3 is dead upstream.

Aah, hmm.

> Even today if you ask a question about exim3 on its main support-list
> (exim-users.exim.org) you'll get a (polite) hint to upgrage to v4
> along the lines of:
> | I've released Eximv4 ${some very long time ago} after developing it
> | for ${at least the same time}. Exim3 is dead, please consider
> | upgrading, I do not know it anymore and cannot answer detail
> | questions about it.
> You are seriously suggesting to ship this already unsupported version
> as default MTA in 2005? (I do not think we'll see sarge 2003.)

Fair enough. Is the upgrade path from exim3 to exim4 utterly smooth?

If not, we should make it optional which to choose, if it is utterly
smooth then let's have exim4 by default, or at minimum a 'one of' choice
of things like exim3 exim4 and postfix.


Daniel Silverstone                               http://www.digital-scurf.org/
Hostmaster, Webmaster, and Chief Code Wibbler          Digital-Scurf Unlimited
GPG Public key available from keyring.debian.org               KeyId: 20687895
Good day for a change of scene.  Repaper the bedroom wall.

Reply to: