[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: failing to compile a KDE package

>   checking for Qt... configure: error: Qt (>= Qt 3.0.2) (library
>   qt-mt) not found.


    ./configure --with-qt-dir=/usr/share/qt3

and see if that helps.  If it does then upstream is using a very old
admin/ directory which should probably be updated.

If the compilation then breaks because of missing headers like
qptrlist.h and so on, install libqt3-compat-headers and optionally flame
the Qt maintainer(s) for not including them in their standard Qt
development installation.  And tell upstream that they're using legacy
headers as the Qt maintainers are expecting you to, which is why they've
chosen to break Qt in this way.

Ben. :)

Reply to: