[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

problems gettingspeakup kernel patch to work with debian kernels (fwd)

Hash: SHA1

I first posted this to debian-mentors earlier today, but decided to post
it here.Also, this is very quickly going outside the range of my skills,
I'm willing to learn,but at this point, it's something I can't really
handle  by myself at this point. If any of you might be willing, I'd like
to try and find a co-maintainer for this package...

- ---------- Forwarded message ----------
Date: Wed, 4 Jun 2003 12:44:41 -0400 (EDT)
From: Deedra Waters <dmwaters@linuxpowered.com>
To: debian-mentors@lists.debian.org
Subject: problems gettingspeakup kernel patch to work with debian kernels

I've been fighting with this for the past couple of days, and slowly
getting it to work, but I'm stuck on this one.

When I go to build the kernel I get theese errors.

make -C speakup
make[3]: Entering directory
`/usr/src/kernel-source-2.4.20/drivers/char/speakup'make all_targets
make[4]: Entering directory
`/usr/src/kernel-source-2.4.20/drivers/char/speakup'cc -o genmap genmap.c
./genmap speakupmap.map >speakupmap.h
can't open ../../../include/linux/speakup.h
make[4]: *** [speakupmap.h] Error 1
make[4]: Leaving directory
make[3]: *** [first_rule] Error 2
make[3]: Leaving directory
make[2]: *** [_subdir_speakup] Error 2
make[2]: Leaving directory `/usr/src/kernel-source-2.4.20/drivers/char'
make[1]: *** [_subdir_char] Error 2
make[1]: Leaving directory `/usr/src/kernel-source-2.4.20/drivers'
make: *** [_dir_drivers] Error 2

I know that it's looking for speakup.h, and I know that it's looking in
/usr/include/linux for it,but what I can't figure out is why isn't it
there, and if it's something I've missed, I'm not really understanding
what I'm missing.

if I could get some help or ideas with this I would really appreciate it.

Version: GnuPG v1.2.2 (GNU/Linux)
Comment: Made with pgp4pine 1.76


Reply to: