[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: May I temporarily move away a conffile of a conflicting package? [Repost]



On Sat, Apr 05, 2003 at 11:22:54AM +0200, Andreas Metzler wrote:
> Currently the exim4-packages cannot provide /usr/sbin/exim (only
> /usr/sbin/exim4) because exim v3's init script up to version 3.36-4
> uses something aequivalent to this to check whether it should do
> anything: [ -x /usr/sbin/exim ] || exit. If you had exim v3
> uninstalled (but not purged) and installed exim v4 and it contained
> /usr/sbin/exim both init-scripts would try to run a daemon. The same
> applies to the cron-snippets.
> 
> The exim3 init script in sid has already been changed to use another
> test that recognizes exim v3 properly but this doesn't help the users
> who will upgrade from woody to sarge (when it is stable), switching
> directly to exim v4 without installing eximv3 from sarge first.

Conflicts: exim (<< 3.36-4)

-- 
  .''`.  ** Debian GNU/Linux ** | Andrew Suffield
 : :' :  http://www.debian.org/ | Dept. of Computing,
 `. `'                          | Imperial College,
   `-             -><-          | London, UK

Attachment: pgpMste3q97Os.pgp
Description: PGP signature


Reply to: