[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Weird dependency in yardradius: what's up?

Hi guys

I probably missed something, but:

Package: yardradius
Priority: optional
Section: net
Installed-Size: 784
Maintainer: Francesco Paolo Lovergine <frankie@debian.org>
Architecture: i386
Version: 1.0.20-5
Replaces: radius-server
Provides: radius-server
Depends: debconf (>= 1.2.9), libpam0g, libpam-runtime, libc6 (>= 2.3.1-1), 
libgdbmg1, libssl0.9.6 
           ^^^^^^^^^^^ Uh? What are you doing here, darling?

Moreover in buildd logs I find:

Download complete and in download only mode
** Using build dependencies supplied by package:
Build-Depends: debhelper (>= 4.1.16), libgdbmg1-dev, libpam0g-dev
**** Warning:
**** The following central src deps are (probably) missing:
  ^^^^^^^^^^  Uh? What? Where? Who?

Well, I wrote that piece of software, I KNOW that I do not use ssl code.
Moreover, openssl have known licensing issues for non GPL-licensed code,
like yardradius, and this give me some problem.

Any hints? Am I missing some hidden dependencies? Is this a known
issue for ${shlibs:Depends}?

Francesco P. Lovergine

Reply to: