[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problem with glibc and crossover office?

On Wed, Oct 23, 2002 at 06:17:52PM -0400, Shaya Potter wrote:
> It stopped working for me sometime (not sure when)

> I get this error that might be related

> /home/spotter/cxoffice/bin/wineloader: relocation error:
> /home/spotter/cxoffice/lib/libntdll.dll.so: symbol __libc_fork, version
> GLIBC_2.1.2 not defined in file libc.so.6 with link time reference

> it at one point deffinitly worked.

> glibc version is Version: 2.3.1-1

> anyone seen this?

Confirmed.  The version of libntdll.so that comes with crossover plugin
references a symbol that's missing from the glibc 2.3.1 package.

You may be able to grab a copy of libntdll.so from a recent wine build
and substitute it for the Codeweavers-provided one.  I'm guessing by the
name that __libc_fork@GLIBC_2.1.2 is an internal system that people
weren't actually supposed to be linking to, so Codeweavers may provide
an update that fixes the problem.

Steve Langasek
postmodern programmer

Attachment: pgp4kiACsLS2d.pgp
Description: PGP signature

Reply to: