[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: perl 5.6 dependent packages

On Sun, Aug 25, 2002 at 06:44:00AM +1000, Brendan O'Dea wrote:
> On Sat, Aug 24, 2002 at 02:49:10PM -0400, Joey Hess wrote:
> >perl 5.8 will enter unstable at the next dinstall run. Before it can
> >make testing though, we have to update the following 84 packages which
> >still depend on perlapi-5.6.*. This list should take into account those
> >packages that were already NMU'd.
> >
> >joey@dragon:~>grep-available -F depends perlapi-5.6 -s package
> Note that in addition, since perl 5.8.0 includes some modules which were
> previously stand-alone, any package declaring a versioned[0] dependency
> on:
>       libdigest-md5-perl, libmime-base64-perl, libnet-perl,
>       libtime-hires-perl, libstorable-perl,
>       libattribute-handlers-perl, libcgi-perl, libi18n-langtags-perl,
>       liblocale-maketext-perl, libmath-bigint-perl, libnet-ping-perl,
>       libtest-harness-perl, libtest-simple-perl
> needs to either have the version for that dependency removed, or just to
> depend on perl (>= 5.8.0).

  If those package are still going to be shipped separately (because
  they're going to evolve outside the perl core), then they should stay
  in the archive and perl must add Provides for them. Hence, the user
  can still choose to use either those in the perl core, or the
  sperate ones (maybe more recent at some point).

Jérôme Marant

Reply to: