[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: perl 5.6 dependent packages

On Mon, Aug 26, 2002 at 09:33:51AM +0200, Jérôme Marant wrote:
>On Sun, Aug 25, 2002 at 06:44:00AM +1000, Brendan O'Dea wrote:
>> Note that in addition, since perl 5.8.0 includes some modules which were
>> previously stand-alone, any package declaring a versioned[0] dependency
>> on:
>>       libdigest-md5-perl, libmime-base64-perl, libnet-perl,
>>       libtime-hires-perl, libstorable-perl,
>>       libattribute-handlers-perl, libcgi-perl, libi18n-langtags-perl,
>>       liblocale-maketext-perl, libmath-bigint-perl, libnet-ping-perl,
>>       libtest-harness-perl, libtest-simple-perl
>> needs to either have the version for that dependency removed, or just to
>> depend on perl (>= 5.8.0).
>  If those package are still going to be shipped separately (because
>  they're going to evolve outside the perl core), then they should stay
>  in the archive and perl must add Provides for them. Hence, the user
>  can still choose to use either those in the perl core, or the
>  sperate ones (maybe more recent at some point).

You're missing the point.

The problem is that some packages have *versioned* dependencies on those
packages: "smokeping" for example depends on "libdigest-md5-perl (>= 2.13-2)".

While perl does have a provide for "libdigest-md5-perl", it's not
considered as there is no version associated.  So the dependencies on that
(and other packages) need to be changed.

As far as retaining the stand-alone versions of [now] uninstallable perl
modules in the archive goes, is there any point?  They can be re-packaged
if/when the need arises.


Reply to: