[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: mozilla-browser conflicts with galeon 1.2.3?

On Fri, May 31, 2002 at 09:40:49AM -0500, Steve Greenland wrote:

> On 30-May-02, 20:36 (CDT), Tom Anderson <granite217@yahoo.com> wrote: 
> > I seem to have spoken too soon... my apologies.  The conflict is really
> > with versions of galeon *less than* 1.2.3, although mozilla's changelog
> > states otherwise (* It does not work with galeon-1.2.3, Conflicts.).  I
> > should have verified this before bringing it to the list.
> The real question is why mozilla declares any relationship to galeon at
> all. Galeon should have a "Depends: mozilla-browser (=1.blah.blah)",
> with the appropriate version. The conflict seems unnecessary.

Galeon does this, with:

Depends: mozilla-browser (>=X)
Conflicts: mozilla-browser (>=Y)

However, presumably it is not always known (at the time that galeon is
built) what the next incompatible version of mozilla will be.  In the
current case, it looks like it was assumed to be 1.0.1:

Conflicts: mozilla-browser (>=2:1.0.1), galeon-nautilus

 - mdz

To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: