[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

ITP: FireBird 1.0 (InterBase 6.0 compatible) - packages available

Package: wnpp
Version: N/A; reported 2002-03-26

Working packages of FireBird 1.0 are available at:
(You may want to set Your http_proxy to
 http://itnunix.itn.pwr.wroc.pl:8080/ to access above site via better
outside world link)

If You're interested in FireBird/InterBase - please try them.
Any opinions, ideas, patches are welcomed.

There are 4 types of packages - by multiplying 32/64 bit IO and two
Server architecutres - Super (threaded) and Classic (standard unix
processes). Plus there is -doc package too.

Warning: they change as I build new and improved versions, but are still
at 1.0.0-1 number, so look at timestamps of the packages!

Things that render them not-yet-ready (besides technical ones):
1. need to fill copyright with proper credits and copyrights
2. need to learn what is the license of bugs/features/opened/closed
  documents in html format
3. need to learn what is the license of release_notes.pdf
4. need to check on what architectures is FB really reported to build.

ad 2 and 3. - authors just didn't decided about it yet (but it didn't
stop them from putting them on website for download). They want to
avoid possible non-original documentation flying around and not
differing from original. Advice here would be greatly appreciated,
You may Cc:firebird-devel@lists.sourceforge.net

ad 4. - from release_notes it only supports i386 and sparc
(we're talking only about Linux systems), but I was told it shouldn't
be too hard to make it working on other arches too - there's one
.h file to be altered about system ID, its endianness etc.
If You want to work on porting FB to other arches - please let me know.

Happy testing!

					Grzegorz Prokopski

To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: