[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: It's Huntin' Season


On Thu, Jan 31, 2002 at 09:17:06PM -0500, Peter S Galbraith wrote:
> There is a caveat to now making it a conffile.  At the upgrade that
> marks the passage of non-conffile to conffile, we get the dreaded
> prompt:
> Setting up gri-html-doc (2.8.6-1) ...
> Configuration file `/etc/emacs/site-start.d/50gri-html-doc.el'
>  ==> File on system created by you or by a script.
>  ==> File also in package provided by package maintainer.
>    What would you like to do about it ?  Your options are:
>     Y or I  : install the package maintainer's version
>     N or O  : keep your currently-installed version
>       D     : show the differences between the versions
>       Z     : background this process to examine the situation
>  The default action is to keep your current version.
> *** 50gri-html-doc.el (Y/I/N/O/D/Z) [default=N] ? 
> So every user will get one prompt for each file we migrate.  :-(

Can't you test in preinst if this file is the one you shipped in the
previous version ov the package ?
If it is the same, you can delete (or better move) it in preinst,so 
config won't complain...
And if it's not the same, you have the question, but you would also have
had it with conffiles...

Please feel free to flame me if my suggestion is stupid.



Reply to: