[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bashism in aclocal?

I am generating a package with libtool/automake/autoconf and ran into a
strange problem: libtool fails to run due to wrong variable substitutions. I
tracked down the problem and the culprit is the libtool section in
aclocal.m4.  Actually, the code in aclocal only behaves correctly if I run
configure through bash:

    $ bash configure
    [ suppressed output ]    
    $ grep libname_spec= libtool 

    $ sh configure
    [ suppressed output ]    
    $ grep libname_spec= libtool 
[My Bourne shell is ash.]

The difference is that "ash configure" is not outputing the backslash when
creating the libtool file.

Is this a known problem?  Is there any fix for it?  Well, I fixed it by
calling "bash configure" in the debian/rules files, but that is ugly.

If that matters : I am using automake 1.5 and autoconf 2.52 (but tried with
1.3 and 2.13 with the same results).

Please Cc: replies to me.

Rafael Laboissiere

Reply to: