[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bashism in aclocal?

On Mon, Dec 03, 2001 at 11:04:09AM +0100, Rafael Laboissiere wrote:
> I am generating a package with libtool/automake/autoconf and ran into a
> strange problem: libtool fails to run due to wrong variable substitutions. I
> tracked down the problem and the culprit is the libtool section in
> aclocal.m4.  Actually, the code in aclocal only behaves correctly if I run
> configure through bash:

If it is really in a libtool-specific macro, this is probably a bug in
libtool.m4, part of libtool. Nothing to do with aclocal, aside from
the fact that aclocal compiles aclocal.m4 from the other .m4 files. I
suggest filing a bug. It might be automake or autoconf, though,
depending on what the specific macro is. More details required.

>     $ bash configure
>     [ suppressed output ]    
>     $ grep libname_spec= libtool 
>     libname_spec="lib\$name"
>     $ sh configure
>     [ suppressed output ]    
>     $ grep libname_spec= libtool 
>     libname_spec="lib$name"
> [My Bourne shell is ash.]

ash is not a Bourne shell.

> The difference is that "ash configure" is not outputing the backslash when
> creating the libtool file.
> Is this a known problem?  Is there any fix for it?  Well, I fixed it by
> calling "bash configure" in the debian/rules files, but that is ugly.
> If that matters : I am using automake 1.5 and autoconf 2.52 (but tried with
> 1.3 and 2.13 with the same results).

The version of libtool you are using would be pertinant, but direct
your comments to submit@bugs.debian.org.

> Please Cc: replies to me.

Set your mail headers appropriately, then. Very few MTAs can parse
obscure little requests in the body of the mail.

  .''`.  ** Debian GNU/Linux ** | Andrew Suffield
 : :' :  http://www.debian.org/ | Dept. of Computing,
 `. `'                          | Imperial College,
   `-             -><-          | London, UK

Reply to: