[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [potato] util-linux won't compile

Adrian Bunk <bunk@fs.tum.de> writes:

> On 28 Nov 2001, Olaf Meeuwissen wrote:
> > Hi .debs,
> Hi Olaf,
> > I'm not having much luck rebuilding potato's util-linux (2.10f-5.1) in
> > a clean, but severely stripped down, potato environment (all essential
> > packages plus dependencies and build-essential basically).
> >
> > The build bombs out on the nfsmount.c compile with a longish list of
> > redefinition warnings and type conflicts of stuff defined in both
> >
> >   /usr/include/linux/in.h and
> >   /usr/include/netinet/in.h
> >
> > and a lack of prototypes for various __swab* and __fswap* functions in
> >
> >   /usr/include/linux/byteorder/swab.h
> >
> > On top of that NFS_PORT and NFS_VERSION are not defined.
> >
> > Does anyone know what's going on and how to fix this?
> this problem is known as #106440. Unfortunately I don't know a solution.
> :-(
> The problem is that in kernel 2.2.17 (?) there was a big NFS backport and
> since the glibc package in stable contains recent 2.2 kernel headers it
> ships these headers. The ancient util-linux version in stable doesn't
> compile with these headers. I asked ajt and joey a good fortnight ago
> whether they'd accept a util-linux-2.10s package although it would be a
> new upstream version - besides the compile problem it will also fix the
> (harmless - but annoying) "nfs warning: mount version older than kernel"
> warning with the 2.2 kernel in potato that was first described in #78735
> (the util-linux-2.10s package I'm talking about is without any changes
> since over 6 months as part of my packages to run kernel 2.4.x on potato
> [1] - I haven't heard of any problems with this package (except one small
> problem with devfs - but that's irrelevant for potato) despite it's surely
> installed by more than thousand people on four architectures - that's why
> I consider it relatively stable).

I think I'll give 2.10s a try then as I was also planning on moving to
a 2.4.x kernel.
> I tried some times to backport the relevant changes to 2.10f but
> this always caused problems and is more likely to break the mount
> package than upgrading to the 2.10s package.

I also tried fixing things, but things only seemed to get worse.
Olaf Meeuwissen       Epson Kowa Corporation, Research and Development
GnuPG key: 6BE37D90/AB6B 0D1F 99E7 1BF5 EB97  976A 16C7 F27D 6BE3 7D90
LPIC-2               -- I hack, therefore I am --                 BOFH

Reply to: