[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: LinuxPPC on PB3400: does any version work?


I think we somehow got cross posted to the wrong mailing
list... Don't ask how?

Sorry debian-devel.

I am copying this message to both lists.

I also did not snip anything so the LinuxPPC users won't
miss anything...

> > How did you get XFree-4.1.99-1b installed on LinuxPPC
> 2000 Q4 ?...
> > 
> > I have tried the RPMS. They tell me I need GLIBC_2.2
> ... 
> Actually, you do not need glibc 2.2. There are two
> XFree-4.1.99-1b rpm packages sets on linuxppc.org, one
> compiled for glibc 2.2 and the other compiled for glibc
> 2.1. I just installed the packages for glibc 2.1.
> You can find the XFree rpm packages for glibc 2.1 on

Ahhh, I will try that out - hopefully it will work.

> >So I went and got
> > glibc_2.2.4 ... Glibc told me it had several conflicts
> with 
> > other versions
> > of glibc. When I did a force install on it, it broke my
> linux 
> > with an error
> > "Fatal: kernel too old" I reloaded the older glibc from
> the 
> > rpms on the CD.
> > So off I went to get the 2.4 kernel. When I load the
> 2.4 
> > kernel, it freezes
> > on a message that the IDE driver failed.
> > The 2.4 kernel I tried was from
> > /users/kfukui/kernel-2.4.x-Ben/kernel-UNI-CPU
> Well, I am using the kernel-2.2.x and glibc-2.1.x that I
> found on the linuxppc CD and I did not try upgrading
> that.
> If you get the XFree packages compiled for glibc-2.1 you
> will not need glibc2.2. I guess upgranding glibc is a
> more difficult task than just upgrading XF.
> > Also, I looked at your info on running XFree with more
> then 8 
> > bits. Just
> > thought the 3400 users who still use the default
> installation 
> > can change
> > /etc/X11/xdm/Xservers to add "-depth 16" before the :0 
> > display number. I'm
> > not sure if this will work with 4.1 as seen above ;)
> I will try that on my PB with XFree 4.1. Probably, on XF
> 4.1 we need add -depth 15 because the colors become
> messed with 16 bits colors on XF4.1. That is the reason I
> suggested using 15 bits colors on my post about running
> XFree with more than 8 bits.

I am not sure why, but I couldn't get -depth 15 to work. To
make it even more peculiar, when X was started with the
-depth 16, In KDE under the X system information, display
:0 depth was listed as 15... Very strange.

Oh yes, I forgot to check the /etc/X11/xdm/Xservers before
I posted - The -depth 16 is actually the _last_ part of the
line... Not that all of us Linux people haven't figured
that out yet ;-)

> I think that your problems will be solved just
> downloading  and installing the XF packages for glibc
> 2.1. I am not a Linux or XFree expert and it worked for
> me. I am sure that it will work for you :)

I'll try that this evening. 


"There's no Such Thing as a Bad Apple"

Do You Yahoo!?
Yahoo! GeoCities - quick and easy web site hosting, just $8.95/month.

Reply to: