[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ALERT: XFree86 4.1.0-3 maintainer scripts hosed; please wait for 4.1.0-4

On Thu, 30 Aug 2001, Branden Robinson wrote:

> Folks might want to wait for 4.1.0-4.  I'm preparing it now.
> Several bugs have already been filed; no one needs to add to them.  The
> problem is understood, and the fix has been written and tested.
> If you already have 4.1.0-3 installed successfully, there is nothing to
> worry about.
> Data points:
> * the problem is in the preinst and postinst scripts of several of the
>   packages, including ones that almost everyone has installed
> * if your /bin/sh is ash, you will likely have this problem

and just in case it is not obvious (or too scary)...

If you have sh linked to ash:
$ rm /bin/sh
$ ln -s /bin/bash /bin/sh
<dselect -> install, or whatever>

...is now working away to install the 58 broken packages I accumulated
over the last couple of upgrades.

Branden, is there anyone who should not do the above?

- Bruce

Reply to: