[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: autoconf version error?

safemode writes:

> Many projects lately have been requiring a dependency on autoconf of 2.5 or 
> higher.  Debian distributes a newer version than this but hides it behind a 
> wrapper script.  If you --version this wrapper script, it replies with the 
> old 2.13 version.  This is bad.  The projects are just looking at that and 
> failing.

In that case, the projects are broken. If you run `autoconf --version'
(i.e., the wrapper script) in a directory which either

 - contains `configure.ac'
 - contains `configure.in', with the line `AC_PREREQ(2.50)'

it will return a version of 2.5x (currently 2.52 on my sid system).
`configure.in' is deprecated, so ask your upstream to switch filenames
if they require a 2.5 version of autoconf.

things change.

Reply to: