[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apt got messed up

"Martin Bialasinski" <martin@internet-treff.uni-koeln.de> writes:

> Bruce Stephens <bruce+debian@cenderis.demon.co.uk> wrote:
> Hi,
>> Sorry, but the following packages have unmet dependencies:
>>   libmime1: Conflicts: kdesupport0g (< 4:1.1.2-final-0) but it is not installable
>> E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
>> But libmime1 is installed, and there's nothing trying to install
>> kdesupport0g that I can see.  "apt-get check" reports nothing wrong.
>> (I'm using unstable.)
> this also drove me nuts, but I found the reason.
> Seems like the debian mirrors I used got somehow inconsistent when
> master was down. 
> I removed all of them from my sources.list, and added ftp.debian.org,
> and all was well again.

That makes sense.  I did much the same thing: I had duplicates (both
ftp.uk.debian.org and another UK mirror for unstable), so I commented
out all except one of each.

Reply to: