[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Build-depends on archaic versions of software wrong!



On Sun, 08 Apr 2001, Christian Marillat wrote:
> Running aclocal  -I macros ...
> aclocal: macros/gettext.m4: 39: duplicated macro `AM_WITH_NLS'
> aclocal: macros/gettext.m4: 233: duplicated macro `AM_GNU_GETTEXT'
> 
> Any idea ?

Well, [new] gettext defines AM_WITH_NLS and AM_GNU_GETTEXT (they're in
/usr/share/aclocal/gettext.m4, btw -- not that it matters, aclocal finds
them well enough).

These macros must not be defined anywhere else. Please search all m4 files
you're feeding to aclocal (the ones in /usr/share/aclocal/) plus the ones in
your macros (subdir or .m4, I don't know. I say that because of the -I
macros) and any ones in acinclude.m4.  You'll probably need to either rename
or (if you're lucky and the gettext ones do all that you want done) remove
them.

-- 
  "One disk to rule them all, One disk to find them. One disk to bring
  them all and in the darkness grind them. In the Land of Redmond
  where the shadows lie." -- The Silicon Valley Tarot
  Henrique Holschuh

Attachment: pgpfuJpdNF_4f.pgp
Description: PGP signature


Reply to: