[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: nautilus1.0 in woody...

Scavenging the mail folder uncovered Aubin Paul's letter:
> On Thu, Mar 22, 2001 at 08:49:57AM +0100, Jan-Hendrik Palic wrote:
> > I use gnome 1.4beta on my woody, schuold this be my problem?
> I think we need to make a FAQ based on the issues people have with
> Ximian's packages. :) Ximian's versioning is different, there packages
> often contain different things. For example, sawfish and sawfish-gnome
> are in both Debian and Ximian. However, they're substantially
> different packages. 

ximian and debian packages are not only "substantially different" but
also incompatible at binary level. some days ago, after upgrading to
nautilus 1.0 in sid and while having still 8-10 ximian gnome packages
(some libraries, bonobo, etc.) nothing worked (nautilus crashed.)
i purged my installation from *any* package with helix or ximian in
it version string and replaced with packages from sid (this is difficult
because ximian varsion is almost always >> than debian one, <g>) and
everything worked again. binary incompatibilities, qed.
> The best thing you can do for your machine is a dpkg -l | grep ximian
> and purge those files, then do an apt-get install task-gnome-desktop
> nautilus. Stick with the Debian packages, because mixing is failing
> for almost everyone.

and the worst part is that they don't have any intention to fix the 
problem of distributing incompatible debs.


Federico Di Gregorio
MIXAD LIVE Chief of Research & Technology              fog@mixadlive.com
Debian GNU/Linux Developer & Italian Press Contact        fog@debian.org
  The devil speaks truth much oftener than he's deemed.
                                   He has an ignorant audience. -- Byron

Reply to: