[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Best way to depend on an xserver but conflict with XF86 v4 ?

On Mon, Sep 11, 2000 at 10:03:04PM -0700, Philippe Troin wrote:
> I have a package (utah-glx) which needs can be used only on a XF86
> 3.3.6 server. How can I express this ?
>   Depends: xserver(<<4.0)
> does not work since xserver is a virtual package.

Yes, version numbers are more or less meaningless in this case.  As someone
else pointed out, there are such things as non-XFree86 X server as well,
though they are rare on Debian systems.  :)

I suggest depending on xserver-common (>= 3.3.6), xserver-common (<< 4.0)
until Stephen Gore and I figure out exactly what we're going to do with
XFree86 3.3.6.

G. Branden Robinson             |   Experience should teach us to be most on
Debian GNU/Linux                |   our guard to protect liberty when the
branden@debian.org              |   government's purposes are beneficent.
http://www.debian.org/~branden/ |   -- Louis Brandeis

Attachment: pgp3S2C0vtx4J.pgp
Description: PGP signature

Reply to: