[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Python 1.6 released and GPL incompatible

Gregor Hoffleit <flight@mathi.uni-heidelberg.de> writes:

    > Python 1.6 was released finally today (for an announcement, see
    > http://www.python.org/1.6/), and it was released under the
    > discussed CNRI license. This license was intended to be
    > compatible with the GPL, but RMS says he thinks it's not
    > (cf. the announcement).

    > [...]

    > That leaves me with two possible solutions:

    > 1) Ignore Python 1.6 and up, as long as the license is not
    > compatible with the GPL.

    > 2) Include both Python 1.5.2 and 1.6 in woody/main.

As long as all the Debian packages that depend on Python work with
Python 1.5 I wouldn't put two Python versions into Debian. Also Python
2.0 will probably be released before the next code freeze and solve
the license issues.

In my opinion things should be kept as simple as possible.

By the way, there's another problem. The modules socket, httplib and
urllib may now be build with SSL support. What to do about these
modules and the source package?

To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: