[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Python 1.6 released and GPL incompatible

On Wed, Sep 06, 2000 at 11:43:21AM +0200, Gregor Hoffleit wrote:
> Still, if 1.6 were to replace 1.5.2, we had to check all packages that 
> depend on Python, if we think their license is still compatible with the 
> new Python license, and remove them if it's not. I'd opt against this.

Yup, that sounds bad.

> 2) Include both Python 1.5.2 and 1.6 in woody/main. The 1.6 packages
>    would not satisfy the dependencies of existing packages; any maintainer
>    who'd make a package depend on Python 1.6 would have to make sure that
>    its license is compatible with the Python 1.6 license.

Install in a parallel tree (/usr/lib/python1.6, e.g) and use
alternatives to manage /usr/bin/python, so that someone can install
1.5 and 1.6 side-by-side.  This would be my favoured solution.


To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: