[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re:auto-login patch for xdm-Buggy and locked Linux

Oswald Buddenhagen wrote:
> > > I agree, we could start xdm in rnlevel 3 and "su someuser startx" in runlevel
> > > 4.
> > >
> > Great,I'll keep an eye and try it as soon as it's done.Thanks.
> >
> why do you want to wait? ;-)
> i attached my auto-login script again. now it has the auto-relogin problem
> nicely solved. if the server crashes, then the session will be restarted
> immediately. if you exit cleanly, then you have to press enter to log in
> again (it is done by a read command. so you could even use this input to
> perform a command, eg, you could make it accept "halt", if you want).
> put the script in /etc/init.d
> then run:
> update-rc.d -f xdm remove
> update-rc.d -f xdm start 99 3 . stop 01 0 1 2 4 5 6 .
> update-rc.d -f autologon start 99 4 . stop 01 0 1 2 3 5 6 .
> this way you get the following runlevels:
> 1: normal single-user
> 2: multi-user without x login
> 3: multi-user with xdm login
> 4: multi-user with x auto-login
> 5: ?
> and here is, how to make it with my xdm patch
> (http://www.inf.tu-dresden.de/~ob6/unix/xautolog.html):
> cd /etc/X11/xdm
> cp xdm-config xdm-config-al
> edit xdm-config-al
>  -> add the auto-login options (see home page)
> cd /etc/init.d
> cp xdm xdm-al
> edit xdm-al:
>  -> change
>     start-stop-daemon --start --quiet --pid $PIDFILE --exec $DAEMON || echo -n " already running"
>   to
>     start-stop-daemon --start --quiet --pid $PIDFILE --exec $DAEMON -- -config /etc/X11/xdm/xdm-config-al || echo -n " already running"
> the following hack is necessary, because we must give xdm enough time to
> exit before it is started again (with the different config):
> edit rc:
>  -> add "sleep 1" before the line
>     "# Now run the START scripts for this runlevel."
>     (line 72 on my system)
> update-rc.d -f xdm remove
> update-rc.d -f xdm start 99 3 . stop 01 0 1 2 4 5 6 .
> update-rc.d -f xdm-al start 99 4 . stop 01 0 1 2 3 5 6 .
> have fun! :-)
> --
> Hi! I'm a .signature virus! Copy me into your ~/.signature, please!
> --
> If Windows is the answer, I want the problems back!
>   ------------------------------------------------------------------------

So.it's a good thing I have experience on how to boot in runlevel 1
run fsck and keep track of all changes.:-)
 You can guess already that things didn't worked.Shortly ,after all
the modifications done to kdm(not xdm since that kept restarting)
system was starting in runlevel 4(not documented but not a problem
for a user with some experience),and locked there in tty2 with an
error message -press Enter to restart X.Tried to login in tty1
as root just to discover that the left SHIFT was disabled (I do have
a few capitals in my password) and after typing the root pasword ,by the
time I got to the shell prompt the system locked completely.CTRL ALT DEL
didn't help so time for hard reboot(took some time since I have 4
partitions 2 GB each and a 1 GB one for / ).Changed the symlinks in
rc.d's back to regular kdm and everything works fine.

My system: AMD K6/2 450 on a ASUS P5A M/B ,Voodoo3 -3000,196 MB of RAM.
I use the framebuffer for Voodoo in shell at 800x600(with a script in
init.d and started from rcS.d and /etc/profile).

My /etc/alternatives/x-window-manager points to /usr/bin/kde since it
was pointing to kdm before RCT1 when suddenly stoped working this way
(kdm was restarting,coming back at the login prompt,the behaviour that
xdm have now with your autologon patch).

I have the latest potato packages from kde.tdyc.com and needless to say
everything works fine..well except XF86Setup-that stoped working after
the upgrade to X-3.3.6-6 -filed a bug report but since I'm trying to
run it in a framebuffer console I don't think it's gonna be fixed too

So anyway I didn't went further with the testing since just one
VT (tty1 ) sucks anyway (I use 2 at least at times) and I don't have
any kernel around compiled without FB support nor old kernel sources
(I'm running 2.4.0-test2 right now).I did try 2.2.16 ,2.2.13 and
2.4.0-test1 to same result .

So if you need nore info about the hardware or my setup no problem,
especially if you make it run with more than 1 VT.

 I still like the idea but for now..sorry it's just not working on my

The best way to escape from a problem is to solve it. 
     Alan Saporta 
My waste of cyberspace=
http://deepblue.dyndns.org :-)

Reply to: