[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#66257: ssh: shouldn't provide rsh-server

Package: ssh
Version: 1:1.2.3-5
Severity: normal

Now, I know this contradicts bug "#63948: ssh: should provide
rsh-server".  It might be best if this issue is raised on debian-devel.
In fact, I have sent a CC (I hope) to debian-devel.

The problem:

heimdal-servers provides rsh-server (Kerberos version). I do not think it
is a good idea to have multiple rsh servers installed at the same
time (even though the Kerberos rsh-server has a different port),
so I have made it conflict with rsh-server.

Now, ssh provides rsh-server, this means ssh and rsh-server
conflict with each other.

I do not think ssh should provide rsh-server unless it
listens on the rsh-server port.

This seems to be a very recent change to ssh that made
its way into frozen, last week.

The twist:

The version of heimdal-servers in frozen is missing the
conflicts rsh-server header (due to an oversight of mine),
so problems aren't encountered until using the potato
version of heimdal-servers. However, I think this
is still important, as I want to be able to use the
latest heimdal-servers (it is my package) with the
ssh that will be in stable.

The resolution:

1. ssh shouldn't provide rsh-server


2. heimdal-servers shouldn't conflict with rsh-server

Personally, I support 1. I dislike 2.
I think having two seperate
implementations of rsh installed on different ports, by two
different Debian packages, is asking for problems.
(sidenote: heimdal-servers also supports non-kerberos
rsh, but not this is not enabled by default).


-- System Information
Debian Release: 2.2
Architecture: i386
Kernel: Linux lyell 2.2.13 #1 Sat Nov 20 12:44:19 EST 1999 i686

Versions of packages ssh depends on:
ii  libc6                         2.1.3-10   GNU C Library: Shared libraries an
ii  libpam-modules                0.72-9     Pluggable Authentication Modules f
ii  libpam0g                      0.72-9     Pluggable Authentication Modules l
ii  libssl09                      0.9.4-5    SSL shared libraries              
ii  libwrap0                      7.6-4      Wietse Venema's TCP wrappers libra
ii  zlib1g [libz1]                1:1.1.3-5  compression library - runtime     

Reply to: