[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dist-upgrade wants to remove scwm

I think I may partly understand the answer:  scwm ultimately depends
on perl-5.005, which apt doesn't want to install.

I tried installing scwm alone, but that led to a chain of broken
dependencies: scwm depends on libesd0, which depends on esound-common,
which depends on debconf, which depends on perl-5.005, which apt won't
install unless explicitly instructed to do so.  Each step along the
way I get an error message telling me that the package to be installed
depends on the next, which is not going to be installed and that I
should report a bug. (See below for an example.)

If I finally tell it to install perl-5.005, then it's happy to
continue, so it appears that my particular problem is solved (although
I haven't yet tried installing the new perl), but this doesn't seem
like the neatest upgrade path.  apt-get dist-upgrade is supposed to
work nicely without removing packages I want to keep.  

It appears that the problem is that perl-5.005 depends on
perl-5.005-base, which in turn conflicts with perl.  apt doesn't seem
to figure out that it can upgrade perl to the new dummy package,
install perl-5.004 to satisfy the dummy perl's dependency, and then
remove perl to satisfy the conflict with perl-5.005-base.

Is there a nicer solution than manually upgrading certain packages
before dist-upgrading, or is this just one of those dist-upgrade
issues that one needs to read about in the documentation prior to
upgrading?  In looking over the release notes, I don't see anything
about a problem like this, so if it is a known issue it doesn't seem
to be pointed out. (By the way, the release notes pointed to on the
web site at http://www.debian.org/releases/frozen/i386/release-notes/
are not in English for some reason.  I got the English language
version -- 2.2.15 -- from the ftp site.)


# apt-get install debconf
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

Sorry, but the following packages have unmet dependencies:
  debconf: Depends: perl-5.005 but it is not going to be installed
E: Sorry, broken packages

mwooding@thecity.sfsu.edu (Miguel Wooding SF Ten.Union) writes:

> apt-get wants to remove scwm when I dist-upgrade, rathern than
> upgrading it.  Any idea why?  This seems like undesirable behavior;
> have I caused it in some way or is something wrong with scwm or ... ?
> apt-get actually wants to remove six packages:
> The following packages will be REMOVED:
>   console-tools console-tools-data egcs-docs netpbm-nonfree open scwm 
> More generally, how can I get apt to explain to me the choices it's
> making? 
> I have a mostly slink machine with a few potato packages, and I was
> looking at what would happen (with apt-get -s) if I dist-upgrade.  I'm
> not certain what more information to report.
> Thanks,
> --Miguel

Reply to: