[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Perl-base -is- essential

On Wed, Jun 14, 2000 at 01:18:37PM -0700, Darren Stalder wrote:
> Julian Gilbey, in an immanent manifestation of deity, wrote:
> >perl-5.005-base is required, but is not listed as essential.  In fact,
> >I've just noticed that one of my packages which uses perl in the
> >preinst should therefore have a Pre-Depends line.  (Any comments on
> >this, anyone?)
> I'll make a comment, as the Perl maintainer.
> perl-5.005-base isn't essential.  But perl-base is.  And perl-base
> depends on perl5-base which is provided by perl-5.004-base,
> perl-5.005-base, and perl-5.6-base.  This way we don't have shifting
> essential packages when we have a new version of Perl.  This was an
> excellent idea from Raphael Hertzog.

I had this feeling that something like this was the case (something in
the vague recesses of my memory).  Couldn't find it just now, though.

Good on you all, and thanks for reminding me!



  Julian Gilbey, Dept of Maths, QMW, Univ. of London. J.D.Gilbey@qmw.ac.uk
        Debian GNU/Linux Developer,  see http://www.debian.org/~jdg
  Donate free food to the world's hungry: see http://www.thehungersite.com/

Reply to: