[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apt-get should correctly process dependencies

On Wed, Apr 26, 2000 at 03:50:53PM +0000, Pedro Miguel Guerreiro wrote:
> Package mailx has broken dep on smail

This is fine, because it's:

Depends: libc6, smail | mail-transport-agent

> Package mailx has broken dep on mail-transport-agent
>   Considering zmailer-ssl 0 as a solution to mailx 8
>   Holding Back mailx rather than change mail-transport-agent

Now this is wrong, it should have picked zmailer-ssl. Anyway, there should
be other packages providing mail-transport-agent, not just zmailer-ssl...

> From what I can see, the problem is with smail. mailx depends on smail,
> but it should depend on exim, as this is the default MTA on a Debian
> system.

That shouldn't be the cause of this problem, although changing the
dependency would be good :)

Digital Electronic Being Intended for Assassination and Nullification

Reply to: