[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Packages referenced but missing from the archive

Martin Schulze wrote:
> Martijn van Oosterhout wrote:
> > I went and grabbed all the Packages files for all the distributions
> > I know of (main, contrib, non-free, non-us/main, non-us/contrib,
> > non-us/non-free), and went and checked wether all the dependencies
> > can be satisfied. As it turns out, there are many packages referencing
> > other non-existant packages.
> GREAT!!!
> > Should I file bugs and if so, what type?
> Bugs need to be filed, though they need proper investigation.

But do you think they are release critical bugs?

> > fortify => fotify-win32
> Looks like a bug in fortify

It actually missing fortify-win32, but yes, it's unlikely to
exist for debian.

> > fvwmconf => fvwm2  (yes! fvwm2 doesn't exist)

Well, it appears the packages were renamed.
fvwm (version <2) => fvwm1
fvwm2 => fvwm (version >2.2)
It's compatability depends for old versions of fvwm, so it's
not strictly a bug.

> Where is fvwm2 gone to?
> > kernel-source-* => gas (there is no gas package)
> bug in kernel-source-*

Hmm, seems to me it could be a bug in kernel-package. I don't know
since I never use it. Need to look into this.

> > gstep-{base,base-dbg,xgps} are all not there
> Who needs them?

Well, actually: gstep-extensions{,-dbg,-dev} but I have the
feeling these are obsolete packages that just havn't been deleted
yet. (Nothing depends on them)

> > jdk1.2{,-native} don't exist

lib-rxtx-java does so it might be in anticipation?
Its Depends line looks like: 
Depends: jdk1.1 (>= 1.1.7v2) | jdk1.2 | jdk1.1-native | jdk1.2-native

> > A few places reference qt1g (should be libqt1g)
> File a bug, recompile should be enough.

Hmm, have done so except for xgmod, which appears to exist in both
contrib and main, with the one in main being correct (and newer).

> > emacsspeak mentions many tclx packages which do not exist
> bad.

Well, the depends looks like:
Depends: tclx80|tclx76|tclx75|tclx74|tclx, emacs19|emacs20

Only tclx76 is present so it will work. However none of the
others are. Seems a misuse of versioning here. Seems unlikely
you could usefully install them all simultaneously.


Reply to: